Jump to content


Some work I've done


41 replies to this topic

#1 5literttop

    Advanced Member

  • Members
  • 193 posts

Posted 25 March 2005 - 04:08 PM

Well I took the base pan off and am going to drilling it for the oil return line... I would have some pics for you but I can't get my camera to register on my parents computer.

I also got the oil filter adapter on. That was fun to get the origional threads out! I destroyed them!!! sledder.gif

Hope to get the engine in this weekend, but If I don't feel up to it, next weekend for sure.

Hey Steve, you said you can host pics?

#2 5literttop

    Advanced Member

  • Members
  • 193 posts

Posted 27 March 2005 - 12:47 PM

Well, today I put the engine back in the car. Got the oil pan all fixed up last night. Flipped the headers. I can't wait to fire it up and hear it again!

It is getting close!

#3 5literttop

    Advanced Member

  • Members
  • 193 posts

Posted 27 March 2005 - 06:32 PM

More progress. I installed the new fuel pump. What a job to do by yourself!

#4 5literttop

    Advanced Member

  • Members
  • 193 posts

Posted 31 March 2005 - 07:34 PM

Here are a couple pics of the engine bay while the engine was out. Used a whire wheel and elbow grease! Lots of Fun!





#5 5literttop

    Advanced Member

  • Members
  • 193 posts

Posted 31 March 2005 - 07:35 PM

This is when I had the tank off and installed the 255 hi-pressure pump. A lot of work to get the tank back in the car by myself.



#6 5literttop

    Advanced Member

  • Members
  • 193 posts

Posted 31 March 2005 - 07:38 PM

This shot(Very fuzy and out of focus) is of the turbo drain fitting in the oil pan. You can also see the ford filter adapter.



#7 5literttop

    Advanced Member

  • Members
  • 193 posts

Posted 31 March 2005 - 07:40 PM

And finally, the engine back in its home.





#8 5literttop

    Advanced Member

  • Members
  • 193 posts

Posted 31 March 2005 - 07:45 PM

I can't wait for the summer!



Just thought I would throw this in there too!

#9 Gixxer750

    2KOOL Team Member aka The 2Kool Eye Candy

  • Members
  • 654 posts

Posted 31 March 2005 - 08:22 PM

Wow Fred, that is way cleaner then when I came out and helped (Stood and drank beer and told you what to do) you take the engine out. You have some time invested under there for sure.

#10 Gixxer750

    2KOOL Team Member aka The 2Kool Eye Candy

  • Members
  • 654 posts

Posted 31 March 2005 - 08:25 PM

One other thing seeing that last pic. For those that can't tell, the Paint on Fred's car is Blue, but it is a different blue, everytime I see it it seems to be a different shade depending on the way the light hits it. First time I saw it when he drove by I thought it was a lighter blue, then the next time I saw it, thought it was purple, very cool color.

And Fred, before this winter you had no experience working on a car you said. You could go write the Master Mechanic exam after all you have done these past few months.

Good job man.

#11 5literttop

    Advanced Member

  • Members
  • 193 posts

Posted 31 March 2005 - 08:49 PM

Thanks Steve! and you did more than drink beer and tell me what to do!!!

Here's another pic of the car.



#12 Gixxer750

    2KOOL Team Member aka The 2Kool Eye Candy

  • Members
  • 654 posts

Posted 31 March 2005 - 10:11 PM

QUOTE (5literttop @ Mar 31 2005, 09:49 PM)
Thanks Steve! and you did more than drink beer and tell me what to do!!!

I suppose I did, because I somehow managed to lose my hat while I was there wacko.gif Still not sure how. I think it may be under the car from when I was working on the header bolts.

#13 5literttop

    Advanced Member

  • Members
  • 193 posts

Posted 31 March 2005 - 10:42 PM

Yea, I moved it to by the door.

#14 5literttop

    Advanced Member

  • Members
  • 193 posts

Posted 07 April 2005 - 05:29 AM

Here is a pic of when I first fired it up! Started on first crank too! I got the tranny on(with a little set back, of course!)



#15 5literttop

    Advanced Member

  • Members
  • 193 posts

Posted 07 April 2005 - 05:29 AM

Here are a couple pics of when I got the crossover on and placed the turbo on it resting place(tranny was not bolted up, so it was sitting high)





#16 5literttop

    Advanced Member

  • Members
  • 193 posts

Posted 07 April 2005 - 05:30 AM

Couple more...




#17 Gixxer750

    2KOOL Team Member aka The 2Kool Eye Candy

  • Members
  • 654 posts

Posted 07 April 2005 - 06:15 AM

Lookin good fred. So did youget the turbo all hooked up?? or is it just sitting in there??

#18 5literttop

    Advanced Member

  • Members
  • 193 posts

Posted 07 April 2005 - 06:44 AM

It was just a test fit, I am going to buy that crossover from another turbomustang guy that works at bretts. It will work, but I need to modify it a little.

#19 Gixxer750

    2KOOL Team Member aka The 2Kool Eye Candy

  • Members
  • 654 posts

Posted 07 April 2005 - 10:21 AM

QUOTE (5literttop @ Apr 7 2005, 07:44 AM)
It was just a test fit, I am going to buy that crossover from another turbomustang guy that works at bretts. It will work, but I need to modify it a little.

Brent Mullens by chance?

#20 5literttop

    Advanced Member

  • Members
  • 193 posts

Posted 07 April 2005 - 10:35 AM

Thats probably him, I don't know his last name. He owns a turbocharged 88 black mustang. It was in the Moncton Atlantic Nationals. He is a very smart guy! That crossover was what he first used on his first turbo project.

I was so glad to hear the 8 cylinders firing! So sweet!

#21 5literttop

    Advanced Member

  • Members
  • 193 posts

Posted 09 April 2005 - 01:18 PM

Here are is a pick of the flange I had made for the oil drain off the turbo:





#22 5literttop

    Advanced Member

  • Members
  • 193 posts

Posted 09 April 2005 - 01:24 PM

These pics are of the intercooler in its new home. Only modification I had to do was cut the notches in the bumper. Only small and you can't see them.




#23 5literttop

    Advanced Member

  • Members
  • 193 posts

Posted 09 April 2005 - 01:25 PM

Here is a front viev of the intercooler. Once it is on the ground, you won't really be able to see it, cause it is low and back... But you can seee it in these pics. banana.gif banana.gif banana.gif





#24 5literttop

    Advanced Member

  • Members
  • 193 posts

Posted 09 April 2005 - 08:34 PM

Got the Oil feed and oil return done. Put some antifreeze in it and started it up. buttrock.gif Sounds so sweet!





#25 stangfreak95

    Advanced Member

  • Members
  • 67 posts

Posted 10 April 2005 - 01:19 PM

Lookin good man. Keep it up !

#26 5literttop

    Advanced Member

  • Members
  • 193 posts

Posted 11 April 2005 - 07:25 AM

Thanks! Its going good! The oil feed is working good as is the drain. I gave the crossover to Brent so he can weld some things on it. I also ordered 10ft of 2.5" and 10 feet of 3" pipe, so I will have all the pipe for the hot and cold sides. banana.gif buttrock.gif

Just need a welder now!

#27 5literttop

    Advanced Member

  • Members
  • 193 posts

Posted 12 April 2005 - 09:17 AM

Got the wastegate flange welded! One more thing done. I will post some pics once I get them!

#28 KDK1988GT

    Member

  • Members
  • 12 posts

Posted 13 April 2005 - 09:04 AM

hey man everything is starting to come togeather.. looking good..

#29 Gixxer750

    2KOOL Team Member aka The 2Kool Eye Candy

  • Members
  • 654 posts

Posted 14 April 2005 - 06:31 AM

Hey K glad to see you pop by. How are things??

Fred car is going great I got your message this morning, I will check and see if I still have a spare when I get home.

#30 5literttop

    Advanced Member

  • Members
  • 193 posts

Posted 14 April 2005 - 06:59 AM

Went to start the f@ck#ng thing last night and I broke one of the posts! Mark started it and I held the positive post on the soledoid! Same post I broke last spring too!